Difference between revisions of "Utilisateur:Sebiseba/WIP/WIP0020"

From Wazeopedia
Line 178: Line 178:
 
<font color='red'>Attention, il n'est plus possible de revenir en arrière une fois l'opération de sauvegarde validée.</font>
 
<font color='red'>Attention, il n'est plus possible de revenir en arrière une fois l'opération de sauvegarde validée.</font>
 
|-
 
|-
| ''Image menu'' || '''Menu Calques'''
+
| [[Fichier:FR_Liste_Calques.PNG|centré]] || '''Menu Calques'''
 
Raccourci clavier : {{key press|L}}
 
Raccourci clavier : {{key press|L}}
 
Le menu des Calques permet, lorsque l'on passe la souris dessus, d'ouvrir un menu déroulant proposant tous les types de calques disponibles à l'affichage. Les cases cochées dans ce menu correspondent aux calques actifs et visibles. Il existe des raccourcis clavier, indiqués plus bas sur cette page, pour chacun d'entre eux (Image n°1).
 
Le menu des Calques permet, lorsque l'on passe la souris dessus, d'ouvrir un menu déroulant proposant tous les types de calques disponibles à l'affichage. Les cases cochées dans ce menu correspondent aux calques actifs et visibles. Il existe des raccourcis clavier, indiqués plus bas sur cette page, pour chacun d'entre eux (Image n°1).

Revision as of 21:14, 9 February 2019

Waze Map Editor (WME)

Waze Map Editor (WME) est le principal outil de cartographie de Waze. Il s’agit d’une application web qui fonctionne sur les principaux navigateurs internet. On accède à WME en utilisant le lien suivant : Waze Map Editor.


1. S’authentifier sur WME link to this section


Vous obtenez un écran (ci-dessous) destiné à vous authentifier sur WME afin que les modifications que vous allez entreprendre soient bien associées à vous, sur les zones où vous disposez des droits pour le faire et avec les prérogatives associées à votre rang d’édition.

Les identifiants sont les mêmes que ceux de l’application. Ils vous permettent également de vous connecter au forum.

WME logon screen FR.png


En dehors des zones de saisies destinées à votre pseudo Waze et votre mot de passe, cet écran d’accueil propose 4 rubriques intéressantes :

Allons-y.png
Une vidéo d’introduction à l’édition


La première rubrique, « Allons-y », propose une série de petites vidéos de présentation et d’introduction à l’usage de l’interface WME. Il s’agit d’une vue très globale essentiellement destinée à présenter le système d'édition de Waze et la facilité d’usage de cette interface. Cependant les vidéos n’abordent pas les règles en vigueur, les bonnes pratiques et les aspects plus techniques de l’édition, qui sont justement traités de manière détaillée et approfondie dans ce wiki.

Wiki de la communauté.png
Un lien vers ce Wiki


Il s’agit d’un lien vers la section Française du Wiki de la communauté Waze, c’est-à-dire la page d’accueil du wiki dont vous êtes en train de lire un article.

Forums FR.png
Un lien vers les forums en anglais sur WME


Il s’agit, pour le moment, d’un lien vers les rubriques consacrées à WME sur le forum officiel de Waze, en anglais. Compte tenu des spécificités régionales et locales, les discussions générales qui ont lieu dans ces forums ne sont pas toujours applicables au contexte français. C’est pour cela qu’il convient plutôt d’utiliser le Forum Français de Waze.

Mode entrainement.png
Le Mode Entrainement de WME


Ce mode permet aux éditeurs débutants de pratiquer les fonctions d’édition de l’interface de WME, sans risquer d’endommager effectivement la Carte puisque aucune des modifications réalisées ne sera enregistrée. Il s’agit d’une fonctionnalité très utile pour faire ses premiers pas, en toute confiance, et sans risque, en particulier lorsqu'on souhaite tester une nouvelle fonctionnalité (par exemple, créer son premier rond-point) et qu’on ignore encore comment l’interface WME réagit à tel ou tel clic de souris ou action spécifique.


2. Présentation de l’interface WME link to this section


Disposition de WME.png

L’interface WME se divise en 3 zones principales :

  • La barre d'outils
  • La zone d'onglets
  • La zone d'affichage de la carte



3. La barre d'outils link to this section

En haut de la fenêtre de l'éditeur se trouve la barre d'outils.

On y trouve dans l’ordre une zone de recherche ainsi que les boutons ou menus : Note de carte, Lieu, Route, [Corbeille], [Actualiser], [Défaire], [Refaire], [Enregistrer] et « Calques »

FR Recherche.PNG Barre de recherche

Raccourci clavier pour sélectionner la barre de recherche : F

Dans la barre de recherche, on peut entrer une adresse, un pays, une ville, un POI ou une combinaison de tout cela. Après envoi de la requête (en appuyant sur Entrée ou en cliquant sur le bouton Rechercher), vous obtenez une liste de résultats qui sont susceptibles de correspondre à votre recherche et parmi lesquels vous devrez choisir celui qui vous convient (voir l'exemple ci-contre).

S'il n'y a pas d'équivoque possible dans votre recherche, vous n'aurez pas cette liste de choix et la Carte sera immédiatement centrée sur le résultat de cette recherche.

FR Note de Carte.PNG
Menu Note de carte

Une note de carte, comme son nom l’indique, permet de laisser une annotation sur la carte à l’intention des autres éditeurs. Les notes n’apparaissent donc pas sur la carte de l’appli et ne peuvent pas être recherchées. Attention donc à ne pas confondre avec un Lieu.


Les notes sont généralement employées pour prévenir d’évolution en cours ou récentes, plus généralement tout ce qui n’est plus identique à la photo satellite (nouveau tracé de route, travaux important, mise en impasse d’une route par des plots,...)


Une note peut être de type Lieu (point) ou Zone.


À lire : Note de carte

FR Lieux.PNG
Menu Lieu

Ce menu permet créer un lieu (appelé aussi Point d’Intérêt ou POI).

Il suffit pour cela de choisir une catégorie de lieu afin de le créer.

Une fois le lieu créé, il conviendra de le renseigner correctement


Un lieu peut être de type Point ou Zone.

À lire : Les Lieux




FR Routes.PNG
Menu Route

Raccourci clavier pour créer une route : I

Raccourci clavier pour créer un rond-point : O

Raccourci clavier pour créer une boîte de jonction : J

Ce menu permet de choisir un objet de route afin de le créer.

Une fois l’objet créé, il conviendra de le renseigner correctement.


NOTAS :

  • La création de radar fixe est réservée aux éditeurs de niveaux 5 et 6.
  • Il n’est pas possible de passer d’un type à l’autre. En cas d’erreur de choix, il sera nécessaire d’annuler et refaire l’objet.

À lire : Les Segments

FR Suppr.PNG
Bouton Corbeille

Le bouton Corbeille supprime tout objet sélectionné. Si vous avez sélectionné plusieurs objets (les seuls objets autorisant la suppression multiple étant les segments), une fenêtre de confirmation apparaîtra.

Le bouton Défaire fonctionne sur les objets supprimés. Comme toute modification, les objets ne seront réellement supprimés qu'après enregistrement des modifications avec impossibilité ensuite de revenir en arrière.

Remarque : le raccourci clavier Suppr ne fonctionne qu'avec un seul objet sélectionné. Les suppressions multiples imposent de passer par le bouton Corbeille et de confirmer l'action.

FR Actu.PNG
Bouton Actualiser

Raccourci clavier : Alt + Shift + R

Cette icône permet d'actualiser l'affichage des calques, ce qui permet de recharger les informations les plus récentes et dans certains cas de résoudre des bugs d'affichage.

Cette méthode de rafraîchissement présente également l'avantage de ne pas réinitialiser toute l'interface WME et donc de ne pas perdre l'historique du Chat en cours.

Fr Undo Redo.PNG
Boutons Défaire et Refaire

Défaire : raccourci clavier: Ctrl + Z

Refaire : Raccourci clavier: Ctrl + Shift + Z


Le bouton Défaire permet d'annuler tout ou partie des modifications réalisées, non encore sauvegardées.

Le bouton Refaire ré-applique les changements qui ont été précédemment annulés avec le bouton Défaire


IMPORTANT: A partir du moment où vous cliquez sur Enregistrer, si l'opération est validée (aucune erreur ne s'est produite), le bouton Défaire ne permettra plus de revenir en arrière.

3 images Bouton [Enregistrer]

Raccourci clavier : Ctrl + S


Le bouton Enregistrer a quatre utilités :

  1. Afficher le nombre de modifications en attente de sauvegarde
  2. Enregistrer toutes ces modifications, lorsqu'on clique dessus.
  3. Informer des modifications en attente d’enregistrement
  4. Informer des modifications validées et incorrectes

À chaque modification apportée sur un objet de la carte, le compteur sur le bouton s'incrémente de 1 (Image n°1).

NOTA : Le compteur correspond au nombre de modifications apportées aux objets de la carte. Par exemple, si vous apportez 5 modifications sur un même objet, le compteur affichera bien 5 mais une seule édition sera comptabilisée sur votre compteur de nombre d’éditions.

Lorsque des modifications de la carte ont été faites mais pas encore enregistrées, un passage de la souris sur le bouton permet d’afficher une fenêtre de dialogue affichant la liste des modifications (Image n°2).

Lorsque le bouton est pressé (ou le raccourci clavier utilisé), WME enregistre tous les changements effectués. Une fenêtre de dialogue affiche un récapitulatif des modifications enregistrées (Image n°3). Si une modification est non conforme, un message d’erreur vous donnera un détail du problème rencontré et vous proposera de le corriger. Les éditions conformes sont quant à elles bien enregistrées.

À l’issu de l’enregistrement, le bouton se grisera si toutes les modifications ont été prises en compte, dans le cas contraire, le chiffre affiché correspondra aux nombres de modifications incorrectes et à corriger. Dans ce dernier cas le bouton [Défaire] fonctionne.

Attention, il n'est plus possible de revenir en arrière une fois l'opération de sauvegarde validée.

FR Liste Calques.PNG
Menu Calques

Raccourci clavier : L Le menu des Calques permet, lorsque l'on passe la souris dessus, d'ouvrir un menu déroulant proposant tous les types de calques disponibles à l'affichage. Les cases cochées dans ce menu correspondent aux calques actifs et visibles. Il existe des raccourcis clavier, indiqués plus bas sur cette page, pour chacun d'entre eux (Image n°1).

« Autre options » permet davantage de choix dans la liste de calques. On y retrouve notamment ceux les moins utilisés comme les problèmes de carte traités ou encore le calque d’édition des noms de villes (Image n°2).

La punaise en haut à droite permet de conserver l’affichage de la liste des calques en permanence, c’est-à-dire même lorsque la souris ne passe plus dessus. Elle est de type ON/OFF.

Les calques sont regroupés sous 4 rubriques principales. La désactivation ou l’activation d’une rubrique permet de masquer ou d’afficher les calques appartenant à la rubrique.

Rubrique « Problèmes »

Cette rubrique comporte 4 calques. Ces calques permettent d’afficher sur la carte l’ensemble des problèmes de carte (UR, MP) et des mises à jour de lieu (PUR).

En activant « plus d’options », il est possible d’afficher ou de masquer les cartes des UR et MP traités.

Rubrique « Lieux et Points d’intérêts »

Cette rubrique comporte 3 calques. Permet au choix d’afficher les lieux résidentiels, les parkings ou tous les autres.

Rubrique « Route »

Cette rubrique comporte 4 calques. Ces calques permettent d’afficher sur la carte les segments et l’ensemble des éléments les affectant.

Rubrique « Affichage »

Cette rubrique comporte 8 calques. Ces calques permettent d’afficher sur la carte des informations additionnelles utiles à l’édition de la carte.

En activant « plus d’options », il est possible d’afficher ou de masquer l’éditeur de nom de ville. Cette option est disponible pour les éditeurs de niveaux 5 et 6.


4. Détails des calques disponibles link to this section

5. Zone d'onglets link to this section

6. Zone d'affichage de la carte link to this section

7. Se déplacer sur la carte link to this section

8. Raccourcis clavier link to this section